Deployit 3.0.1 released

Follow

XebiaLabs Support -

Deployit version 3.0.1 has been released. This is a bug fix release. These are the release notes:

Release Notes - Deployit Product Backlog - Version server-3.0.1


** Bug
    * [DEPLOYITPB-1443] - Unable to import DeployableArtifact CIs with required properties
    * [DEPLOYITPB-1444] - Unable to import a CI that has a required property which references other CIs (i.e. is not simple)
    * [DEPLOYITPB-1459] - UI: ConfigurationFile mapping: 'Create directory if not exist', check box state is not persisted 
    * [DEPLOYITPB-1583] - Unable to authenticate against LDAP
    * [DEPLOYITPB-1607] - LDAP does not work on the IBM JDK




** Story
    * [DEPLOYITPB-1387] - Support comparison of folder artifacts so that only modified ConfigurationFiles (etc.) are redeployed
    * [DEPLOYITPB-1505] - Copy folder-based artifacts without opening a connection per file
    * [DEPLOYITPB-1507] - Allow plugin-api steps to request that they be paused

Do the following to upgrade an existing Deployit 3.0 installation:

  • extract the distribution zip file. You will find release notes, a server zip and a CLI zip inside. 
  • make a backup copy of your Deployit installation by renaming the current Deployit installation directory. 
  • create a new directory with the original name of the installation directory. 
  • extract package-3.0.1-server.zip in this directory. 
  • copy the contents of the conf and repository directories from the backup directory into the installation directory. 
  • copy the contents of the importablePackages directory from the backup directory into the installation directory. 
  • copy the contents of the plugins directory from the backup directory into the installation directory.

Now, you can start the server in the usual way.

To install the CLI, do the following: 

  • make an installation directory specifically for the Deployit CLI. 
  • extract package-3.0.1-cli.zip in this directory.

Start the CLI from the bin directory in the CLI installation directory in the usual way.

Download your copy from http://tech.xebialabs.com/deployit/3.0.1/deployit-3.0.1.zip.

Update 1/4/2011: Deployit 3.0.1 also requires a new version of your plugins. When upgrading, please contact us for this.

Have more questions? Submit a request
Powered by Zendesk