Post

3 followers Follow
0
Avatar

Question: How to treat French characters in the Notification Task?

I would like to send emails in French, using Notification task. However the system doesn't recognize the accents.
Is there a workaround available?

Claire Gaulin

Please sign in to leave a comment.

14 comments

0
Avatar

Hi Andrew
I would like to upload the screenshot but I do not see any upload feature.
How should I proceed?
Claire

Claire Gaulin 0 votes
0
Avatar

Hi Claire

> I would like to upload the screenshot but I do not see any upload feature.

Er...good point ;-) I forgot to provide instructions for that, sorry. Could you upload them to something like snag.gy?

Regards

Andrew

Andrew Phillips 0 votes
0
Avatar

Hi Claire

You can see that the é appears in the subject but will not display in the body of the message.

I see, yes - thanks for uploading the screenshot. I also notice that it doesn't like the apostrophes that you are using (e.g. in s?assurer) - is it possible that the email body is being pasted from e.g. Microsoft Word, or another program that may use non-ASCII characters?

Could you try to send yourself a test email with the body

An example body with é

copy-pasted from here to see if that works? I'm going to test that with my 4.6.0 installation right now...

Regards

Andrew

Andrew Phillips 0 votes
0
Avatar

Hi Claire

> I'm going to test that with my 4.6.0 installation right now...

Creating a notification with a body copy-pasted from here seems to work for me: http://snag.gy/ehX9k.jpg

If it still doesn't work for you, is there a way you could try to send this to a different email address, and/or using a different SMTP server? I'd just like to try to rule out the user's email client and/or the SMTP server as the possible cause of the issue.

Regards

Andrew

Andrew Phillips 0 votes
0
Avatar

Hi Claire

> It still won't display in the body.

Hm...odd! I wonder whether the codepage is different, i.e. whether it's potentially a setting in the email client?

Could you check the message encoding (see http://snag.gy/droLx.jpg) and perhaps also forward that email to this temporary email address: g6501199@trbvm.com?

Thanks!

Andrew

Andrew Phillips 0 votes
0
Avatar

Hi Claire

> For encoding I have Unicode (UTF-8) see http://snag.gy/Nh55j.jpg

What happens if you change the encoding to Western European?

> I forwarded the email to the address you gave me.

Sorry, I pasted the wrong temporary email address :-( Could you kindly forward the email to this address instead: g6502468@trbvm.com?

Thanks!

Andrew

Andrew Phillips 0 votes
0
Avatar

Hi Claire

What happens if you change the encoding to Western European?

If I set the encoding for my test email to UTF-8, the é character doesn't display correctly, just as you're seeing: http://snag.gy/HBuza.jpg. So I would imagine that the encoding setting is the problem here.

If that is the case for you too, it would be good to find out whether the email is at least being sent with the correct encoding setting. Could you right-click on the test email in Outlook, then click "Message Options" and copy the contents of the "Internet headers" field (http://snag.gy/ZYb4U.jpg) into a text editor?

If you then search for the string Content-Type, do you find anything? The headers of my test email contain the following line:

Content-Type: text/plain; charset="Cp1252"

and it would be useful to know if you have the same charset, or a different one.

Thanks!

Andrew

Andrew Phillips 0 votes
0
Avatar

Hi Claire

We reproduced the bug, thanks for reporting! It looks easy to fix, so we hope we can provide you with a solution soon.

Kind regards,

Hes Siemelink

Hes Siemelink 0 votes